Analytics
263 Usuários online agora
263 Usuários online agora
Espaço para questões e aprendizados sobre visitas, tráfego de referência e etc.
Guie-me
star_border
Responder

Analytics parou de funcionar!!

Calouro ✭

Olá,

o google analytics parou de contabilizar as visitas no meu site. Eu até ja criei outra conta no google para tentar resolver o problema, mas ele funcionou por um tempo e parou novamente. Eu fiz no site apenas uma página de testes, mais simples possível, para ver se voltava a funcionar, mas não funcionou. O código está colocado corretamente, logo após a tag <body>, mas não importa o que eu faça, ele não funicona. O que pode estar ocorrendo??

Especialistas responderamverified_user

Re: Analytics parou de funcionar!!

Principal Colaborador
O snippet do Google Analytics deve ser implementado dentro do header e não no body. Se você tiver disparando via GTM ai sim, pois o snippet do GTM é dentro do body.
Ricardo Gaya

Minha resposta foi útil? Se sim, clique em "Aceitar como solução". Saiba mais aqui.

Re: Analytics parou de funcionar!!

[ Editado ]
Calouro ✭

Muito obrigado pela ajuda Ricardo Gaya, e me desculpe se eu estou sendo um pouco inesperiente no assunto, mas eu vou lhe dizer exatamente o que eu fiz.
Primeiro eu criei a conta no Google Analytics, e fui até a aba Administrador > Informações de Acompanhamento > Código de Acompanhamento.
Lá eu copiei o código de acompanhamento e colei nas páginas que eu queria que fossem rastreadas (2 páginas simples de teste). A informção lida lá foi a seguinte:
"Para aproveitar todas as vantagens do Universal Analytics para essa propriedade, copie e cole o código em todas as páginas da Web que você deseja acompanhar."
E mais abaixo:
"Adicione a linha a seguir a cada página do modelo imediatamente depois da tag de abertura <body>"
As páginas de teste criadas tem o seguinte formato:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="pt-br" lang="pt-br" xmlnsSmiley surpresog="http://opengraphprotocol.org/schema/">

<head>

<meta http-equiv="Content-Type" content="text/xhtml; charset=iso-8859-1" />

<title>Teste</title>

</head>


<header>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-xxxxxxx-1', 'auto');
  ga('send', 'pageview');

</script>
</header>


<body>

<h1> Teste do Google Analytics </h1>
<br>
<a href="tests_analytics/index.php">Pagina 2</a>


</body>
</html>

Contudo, o código não funcionou.
Eu tentei colocar o código de acompanhamento dentro da tag <header> como você disse, mas também não funciou. Então, o que eu posso estar fazendo errado?

Re: Analytics parou de funcionar!!

Calouro ✭
eu uso o analytics há mais de uma ano apara rastrear visitas da minha loja virtual. E há alguns dias, ele simplesmente também parou de contabilizar visitas em especial as que vem das redes sociais. Não mudei nada, simplesmente ele parou. E sei que está havendo visitas normalmente pois recebo os pedidos em meu email, acompanho na loja a movimentação do cliente no carrinho e o gráfico do analytics mostra só 0 visitantes. Não sei o que houve nem como resolver.

Re: Analytics parou de funcionar!!

Principal Colaborador

@Opublli D

 

Essa opção de implementação dentro do <body> são usadas em em alguns casos como CMS e alguns outros, mas mesmo assim não é a melhor maneira. Tanto que na página que você viu essa informação esta como Opcional. Certo?

 

Olha o que diz a página do suporte:

Website estático

No website estático, a página HTML NÃO é gerada por meio de uma linguagem de programação ou interface, como Python, Ruby, PHP etc. Para coletar dados, você precisa copiar e colar o código de acompanhamento do Google Analytics no código-fonte em todas as páginas da Web que deseja acompanhar.

  1. Quando tiver o snippet de código de acompanhamento Javascript para sua propriedade, copie-o exatamente, sem editá-lo.
  2. Cole seu snippet de código de acompanhamento (sem alterações, integralmente) antes da tag de fechamento </head> em todas as páginas da Web que você deseja acompanhar no seu site.

Se quiser coletar dados de páginas da Web para várias propriedades de uma vez, veja como acompanhar uma página usando várias contas ou propriedades.

 

 

 

Esse me parece o seu caso. Certo?

 

Seu código tem um erro, pois o header esta fora do body. Na verdade eu também não me expressei bem. O correto seria dentro do <head></head>, e acabei escrevendo header por gira do dia a dia. Modifiquei seu código e com essa alteração ele deve funcionar corretamente até mesmo em localhost se tiver conexão com a internet. 

 

 

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="pt-br" lang="pt-br" xmlnsSmiley surpresog="http://opengraphprotocol.org/schema/">
	<head>
		<meta http-equiv="Content-Type" content="text/xhtml; charset=iso-8859-1" />
		<title>Teste</title>
		<script>
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
		ga('create', 'UA-xxxxxxx-1', 'auto');
		ga('send', 'pageview');
		</script>
	</head>
	<body>
		<h1> Teste do Google Analytics </h1>
		<br>
		<a href="tests_analytics/index.php">Pagina 2</a>
	</body>
</html>

 

Não se esqueça de corrigir a UA. Ok?

 

Abraço.

Ricardo Gaya

Minha resposta foi útil? Se sim, clique em "Aceitar como solução". Saiba mais aqui.

Re: Analytics parou de funcionar!!

Principal Colaborador

@Opublli D,

 

Uma recomendação é que você implementa em TODAS as páginas do seu site. Piscadela do Smiley

 

Link de referência oficial - https://support.google.com/analytics/answer/1008080?hl=pt-BR

Ricardo Gaya

Minha resposta foi útil? Se sim, clique em "Aceitar como solução". Saiba mais aqui.

Re: Analytics parou de funcionar!!

Principal Colaborador

@Carolina G, tudo bem?

 

Você verificou se o snippet do GA continua sendo disparado em todas as páginas e corretamente? Se sim, houve alguma alteração como criação de filtros, alterações no agrupamento padrão de canais ou algo do tipo?

 

O único canal que deixou de registrar as informações é Redes Sociais???

Ricardo Gaya

Minha resposta foi útil? Se sim, clique em "Aceitar como solução". Saiba mais aqui.

Re: Analytics parou de funcionar!!

Calouro ✭
Eu não alterei nenhuma configuração do GA... As redes sociais foi onde eu realmente notei a queda absurda, pois é de onde recebo mais tráfego. Agora mesmo recebi dois pedidos e não vi no GA nenhuma movimentação de meus clientes fazendo as compras.

Re: Analytics parou de funcionar!!

[ Editado ]
Calouro ✭

@Ricardo-Gaya,

Mais uma vez eu lhe agradeço pela ajuda, mas eu fiz exatamente o que você disse e infelizmente não funcionou (E sim, eu corrigi a UA). Copiei o código que você postou e colei nas páginas de teste, mas não foi contabilizada nenhuma visita.

Eu olhei a página de suporte que você enviou, e tentei de todas as maneiras, mas mesmo assim não deu certo. Eu testei em páginas de teste .html e .php, em nenhuma funcionou.

Apesar de a estrutura dessa pagina teste que eu postei estar em html, ela é uma página php, pois as páginas do meu site serão em php. Dessa maneira, eu tentei utilizar o arquivo "analyticstracking.php"  da seção "website dinâmico", mas também não funcionou.

A idéia da página de teste é para ter certeza que nunhum script nas minhas páginas poderiam estar atrapalhando que o snippet do GA fosse disparado, e eu já vi que não é isso, pois como você pode ver, a página de teste é a mais simples póssivel, e mesmo assim não é contabilizada nenhuma visita.

Como eu disse, eu não imagino o que possa estar acontecendo, pois ele estava funcionando corretamente, e simplesmente parou de contabilizar.

Se você tiver mais alguma dica, eu agradeceria muito, pois eu não sei mais o que fazer.

Re: Analytics parou de funcionar!!

Principal Colaborador

Olhei a página teste hospedada e esta disparando sim os hits para o servidor do GA.

 

Como você esta validando isso?

 


_ _ _ _
| | | | | | (_)
__ _ ___ ___ __ _| | ___ __ _ _ __ __ _| |_ _| |_ _ ___ ___
/ _` |/ _ \ / _ \ / _` | |/ _ \ / _` | '_ \ / _` | | | | | __| |/ __/ __|
| (_| | (_) | (_) | (_| | | __/ | (_| | | | | (_| | | |_| | |_| | (__\__ \
\__, |\___/ \___/ \__, |_|\___| \__,_|_| |_|\__,_|_|\__, |\__|_|\___|___/
__/ | __/ | __/ |
|___/ |___/ |___/

Running analytics_debug.js. This script is intended for testing and debugging only.
Initializing Google Analytics.
Running command: ga("create", "UA-80562030-1", "auto")
Creating new tracker: t0
Auto cookieDomain found: "opublli.com"
Running command: ga("send", "pageview")

Sent beacon:
v=1&_v=j44d&a=1171257737&t=pageview&_s=1&dl=http%3A%2F%2Fopublli.com%2F&ul=pt-br&de=windows-1252&dt=Teste&sd=24-bit&sr=1920x1080&vp=1873x244&je=0&fl=22.0%20r0&_u=AACAAMABI~&jid=&cid=498293252.1468867077&tid=UA-80562030-1&z=1360424538


_j1 (&jid)
adSenseId (&a) 1171257737
apiVersion (&v) 1
clientId (&cid) 498293252.1468867077
encoding (&de) windows-1252
flashVersion (&fl) 22.0 r0
hitType (&t) pageview
javaEnabled (&je) 0
language (&ul) pt-br
location (&dl) http://opublli.com/
screenColors (&sd) 24-bit
screenResolution (&sr) 1920x1080
title (&dt) Teste
trackingId (&tid) UA-80562030-1
viewportSize (&vp) 1873x244
Registered new plugin: ga(provide, "render", Function)

Ricardo Gaya

Minha resposta foi útil? Se sim, clique em "Aceitar como solução". Saiba mais aqui.